8.3 250 hp 1993 pusher. Won't keep running

Discussion in 'Class A / Diesel Pushers' started by sepisllib, May 9, 2006.

  1. sepisllib

    sepisllib New Member

    For some reason my 93 Tourmaster has developed a problem.

    It starts up just great (switch in start position). Then - when I release the ignition switch to the run position (as engine has started) - it promptly dies.

    My power for rear view monitor comes from the same switch in the "run" position and that still works (plus I replaced the igntion switch last fall).

    BUT - I can turn switch on and off, 5 or 6 times in quick sucession and then try starting it and it starts and keeps running when the switch is released to the run position.

    I did replace the solenoid (start one on the frame) last week. It did not do the trick.

    Thoughts?

    Bill
     
  2. TexasClodhopper

    TexasClodhopper Senior Member

    8.3 250 hp 1993 pusher. Won't keep running

    "I can turn switch on and off, 5 or 6 times in quick sucession and then try starting it and it starts"

    I think this proves that it is again your ignition switch that is causing the problem.
     
  3. sepisllib

    sepisllib New Member

    8.3 250 hp 1993 pusher. Won't keep running

    Thank you for the suggestion, however my backup monitor continues to work in each case of these failures and it uses the same power wire as the fuel shutoff solenoid.

    I think I have narrowed it down now. From examining it closely it appears that my fuel shutoff solenoid is dropping out intermitently.

    Hate to buy that darned thing - it's the size of the old starter solenoids used years ago (mounted on the fenderwell of the cars) - but in this case it runs around $300.

    Going to pick one up tomorrow and install it.

    Bill
     

Share This Page