Allegro Bus starts and immeadiately dies when I release key

Discussion in 'Class A / Diesel Pushers' started by ripfish, Jun 19, 2009.

  1. ripfish

    ripfish New Member

    I have a 96 Allegro Bus with Cummins motor. I went to start it up after parking it two days ago. I am trying to take it in for service. Rear Airbags flat and transmission issues.

    So I allowed it to go through glow plug cycle. It starts right up and dies as soon as I let go of the key. It will do this over and over. Surely the problem is electrical. Can anybody give me guidance? There are "Ford" relays behind the dash that click on and off with the key. There also is some starter relays on the frame by the engine/starter. Seems like the starter relay is working fine. More of an key relay issue.
    Help?
     
  2. gatorcq

    gatorcq Banned Users

    RE: Allegro Bus starts and immeadiately dies when I release key

    You should go to this site for your question, it may be a better place.
    http://autos.groups.yahoo.com/group/Diesel-RVs/
    However, diesel needs only 2 thing Air and Fuel. Once it starts you have to remove one or the other to stop it. Are you sure your fuel solenoid is staying on?


    dale
     
  3. diamondave

    diamondave New Member

    RE: Allegro Bus starts and immeadiately dies when I release key

    Derek,
    I read about your problem with the starting on your Alegro Bus. I have the same thing going on with my Holiday Rambler with a cummins engine.
    Did you find a solution to the problem? Can you help me with this?
     

Share This Page