allison 4000 series trans

Discussion in 'General RVing' started by gringo, Jun 12, 2006.

  1. gringo

    gringo New Member

    allison man I recently took my 2001 prevost in to a local shop to do a recall on series 60 detoit diesel, and while it was in there I thought it would be a good time for a service. The trans had delvac 1300 15-40 oil in it. So I asked if we could put trans synd oil in it they called me later and said it was the prefferd oil. anyway just before going to pick up the bus they called and said it was stuck in neutral,and asked if I had any problems with it I replied no. Now I just purchased the bus it had 27,000 mi on it and I drove it from Tehachipi,CA. to Central Point,OR and the Bus performed beautifully, the trans shifted better than my previous 1997 prevost with 90,000 mi on it. The local shop is now taking the trans out and said I was lucky this didn"t happen out onthe road. Which I agree with that theary, but I dont what they could have done to it to cause the prblem. But they say I will Have to pay for It. Can you give me your professional opinion on my bus broke at shop problem. p.s. no oil pressure is the problem. could it be there fault. Thanks Gringo
     
  2. gringo

    gringo New Member

    allison 4000 series trans

    allison man, Irecently took my 2001 prevost in to a local shop to do a recall on a series 60 detroit diesel, and while it was there I thought it would be a good timme for a full servis on the engine and trans. The trans had delvac 1300 15-40 oil in it. So I asked them if they could change it to Trans Synd oil, they called me later and told me it was the prefferd oil, so they would change it to trans synd. Anyway just before going to pick up my bus I get this phone call telling me the trans is stuck in neutral,and asked if I had had any problems with it, I replied No. Now I just purchased this bus with 27,000 mi. on it and drove it from Tehachipi,CA. to Central Point,OR. and the bus performed beautifully,the trans shifted better than my previous 1997 prevost with 90,000 mi. on it. The local shop is now taking the trans out and said I was lucky this didn't happen out on the road. ( no oil pressure) Which I agree with that theary, but I dont no what they coud have done to caus the problem. they say Im responsible for the problem. Can you give me your proffesional opinion on my bus broke at local shop problem. Could it be there fault??? Thanks Gringo
     
  3. dbarton291

    dbarton291 Senior Member

    Re: allison 4000 series trans

    This local shop. Is it an Allison dealer with an Allison Transmission sign outside? Don't see how a 4000MH with 27K miles could be failed.
     

Share This Page