Atwood 6 gal lp/electric water heater

Discussion in 'Talkback' started by ARCHER, Oct 8, 2012.

  1. ARCHER

    ARCHER Senior Member

    Just got back to Florida for winter. All works except water heater. Won't lite on lp or electric. Worked fine when we left in spring. In Sunnybrook Sunset Creek trailer. When I flip switches for either elecgtric or lp light comes on but then DSI/FLT light comes on and nothing works. Took board off and had tested at RV dealer and they said board is ok. Have scheduled service call, but any ideas of what might be wrong? Tank was flushed, and new anode put in drain hole.. I had replaced the ECO/THERM just last year. Need help soonest, before they show up to fix ($100 to just get here)
     
  2. C Nash

    C Nash Senior Member

    Archer did you purge the gas system good before trying to use on gas? Mine has a little diode type thing that can be reset on electric. Might have to replace it. About the size of a dime.
     
  3. Guest

    Guest Guest

    well archer ,, i know this will sound like old school stuff ,, but ck the breakers and fuses ,, and also the switch that goes from lp to elect. i am sitting here thinking right now of what i have seen about this same thing ,, :) i just thought of cking the thermostat ,, maybe or maybe not ,, and don't take this wrong ,, but it is full of water right ??? not in the bypass mode ?? i am not trying to inplie anything ,, just saying ,, IMO sounds like u might have a thermo prb ,, but i kinda feel u might have an electrical issue ,, some where ,, i really hate it when i "just try to help" but i can't ,, i know i could solve the problem if i was there ,, (well most of the time) but i have that feeling ,, it is a wiring issue ,, and not much more ,, but "hey" this is JMO ,, so that others know :concern::concern::applause:
    Btw ,, where are u staying ?? i will be in FL the middle of Nov. ,, and it would be great to meet u ,, where ever u are staying
     
  4. H2H1

    H2H1 Senior Member

    well if it just on propane I would suggest cleaning the orfice. Well mine was clogged at the orfice so a tooth brush cleaned it up, no more problem
     
  5. LEN

    LEN Senior Member

    Check the 12 volt power to the heater. Can you bridge the thermostat? Is the a fuse on the heater itself? Is the switch in the trailer working even when the light says it is?

    LEN
     
  6. C Nash

    C Nash Senior Member

    Brain missed the not working on electric or gas. Was just thinking gas. Probably done paid the tech to come out now so let us know what you find Archer. With nither electric or gas working I tend to agree with 12 volt problem somewhere.
     
  7. ARCHER

    ARCHER Senior Member

    Thanks for all the info. I made sure tank is full, all circuit breakers are ok, took board to rv dealer and checked out ok, thermocoupler is ok, fridge works so 12 volt power is getting thru system at least to fridge, and lastly everything else seems to be working fine. I even cleaned ECO and Thermo and tank where gthey touch. Light comes on when I turn on 110 volt electric on panel, but then small light pops on that shows DSI FLT and this is also the case with the LP switch. First time I have ever been totally stumped. The dealer will come out next tuesday to determine problem and hopefully fix it. Yesterday, I got brave and took a cold shower.......won't do that again.....whew.
     
  8. Guest

    Guest Guest

    with the DSI FLT ,, that is a fault in the main power center ,, do u have the intellitech system on ur rv ??? what i am saying is a power management sytem ,, but looking into the DSI part , it coud be digital signal interupt ,, if it is on the Intell system ,, but let all know back
     
  9. ARCHER

    ARCHER Senior Member

    Well the repair guy just left. I feel really dumb. AFter all these years of doing my own repairs, I failed to fix the easy one. The ECO was bad. Also, the ignitor for LP was also bad (wire shorted out). Both parts cost around $70.00 bucks but labor and service call jumped it up. I have replaced the ECO and Therm before so don't know why I went brain dead on this one. Anyway, water is already heated up so hot shower tonight. tks for all the help
     
  10. H2H1

    H2H1 Senior Member

    sometimes we have a brain fa**, and look stupid, oh well the main thing is it is fixed. I know the $70 plus service call really sucks, but you will rememeber next time.
     
  11. mel stuplich

    mel stuplich Junior Member

    ECO? WTF is an ECO??
    And what does Therm stand for?
    Just a few more keystrokes and we might be able to understand what you are saying!
     

Share This Page