Atwood 8500 furnace problem

Discussion in 'General RVing' started by dick auge, Oct 27, 2008.

  1. dick auge

    dick auge New Member

    My furnace has an intermittent problem. Sometimes the blower does not shut off when it gets up to the proper heat. The heating part works properely. Probably a circuit board or thermostat? Any easy solution or way to check out? Thanks
  2. ironart

    ironart New Member

    Re: Atwood 8500 furnace problem

    Hi Dick and Welcome....

    RV thermostats are, at best, 10%+/- on that is a lot of latitude for error in temp.....if you can shut off the unit with by moving the temp setting to a lower temp than that is what you are going to have to do....or replace the stat....

    When an RV thermostat shuts off.....It removes power to the furnace controls.... if everything else works then it is not a circuit is the Stat....
  3. ironart

    ironart New Member

    Re: Atwood 8500 furnace problem

    Dick......Just a follow up......I had a furnace that would shut off the gas (from the Tstat) but the blower would continue to run......The problem was in the "timed relay" that allows the blower to run a minute or so after the gas was shut off.......This relay would not release and had to be changed......about a $30.00 item...
  4. utmtman

    utmtman Senior Member

    Re: Atwood 8500 furnace problem

    I had a similar problem and it was the circuit board at the furnace.

    ARCHER Senior Member

    Re: Atwood 8500 furnace problem

    I removed my furnace and took it to a RV shop to have it bench tested....lot cheaper than driving the ole gal 25 miles each way and leaving it there several days. Turned out it only needed some maintenance work and the relay for the fan that Ironart mentioned. Removing it was pretty easy. A few screws and a wire with plug for electric worked great for the next two years and then we sold the RV, but it was still working fine. I think they charged me like $25.00 to bench test the furnace and about $30.00 for he repair. ;)

Share This Page