atwood water heater

Discussion in 'Towables' started by mtswampfox, Nov 11, 2009.

  1. mtswampfox

    mtswampfox New Member

    spent last couple of weeks in the georgia woods in my 28 jayco with a dual [electric/gas] water heater . first time using the gas side of the heater in the 2007 trailer. the unit would ignite for the cycle sometimes on first or second attempt, sometimes would ignite for a second then go out then retry. one time it made three unsuccessful attempts, had to re-cycle start switch then would run. igniter seems fine , not sure if brain could be going or flame sensor?????
     
  2. ARCHER

    ARCHER Senior Member

    Re: atwood water heater

    If it was never used or not used very often, might have "bugs" in the lp tube flame area. Make sure it is clean. Might be preventing lp from getting to the ignitor. Just a thought.
     
  3. mtswampfox

    mtswampfox New Member

    RE: atwood water heater

    when it does stay lit for the cycle it has a beautiful flame, but will take burner off now that i am settled in for the winter using the electric side of the heater
     
  4. H2H1

    H2H1 Senior Member

    Re: atwood water heater

    Hello Michael and welcome to the forum. I am just wandering where you are camping in North Ga. mountains. :question: :approve:
     
  5. mtswampfox

    mtswampfox New Member

    RE: atwood water heater

    was at hunt camp in juliette usually spend last of march/first of april there,also two weeks in nov. currently in brunswick for the winter in county park. will head back to nw indiana in spring
     

Share This Page