Atwood Waterheater won't stay lit

Discussion in 'Class C Motorhomes' started by nineoaks2004, Aug 19, 2013.

  1. nineoaks2004

    nineoaks2004 Junior Member

    I have an Atwood water heater DSI Model G6A8E it will light for about 30 seconds then shut down. I have cleaned the tubes, checked the grounds, the ECO reads with an ohmmeter, as does the thermostat,I get a reading with the thermal cutoff (I am not to sure about this one tho.) I even tried temporarily by-passing the ECO and thermostat.
    The 2 coils on the gas regulator seem to be working as I can hear them close when it shuts down.. Any Ideas on what the problem can be, I do not want to start changing parts until something works..
  2. LEN

    LEN Senior Member

    Sounds like a themocouple either needs cleaned or replaced. Or you didn't run out of gas or have the water heater off for a time. If so try lighting it several times to make sure of gas flow.

  3. nineoaks2004

    nineoaks2004 Junior Member

    It doesn't have a thermocouple, it's a DSI, I have 3/4 tank of LP I tried all weekend to get it up, then took everything apart and cleaned all parts, still does the same thing...
  4. vanole

    vanole Senior Member

    Could be the gas solenoid valve giving you the trouble.

    Have you checked the main burner orifice?

    Could also be improper air adjustement. If I remember correctly the air shutter needs to be about 1/4 open.

    Do other items that run on LP work as advertised stove, furnace?
  5. nineoaks2004

    nineoaks2004 Junior Member

    I tried all of that, other appliances, furnace, stove.. work good. It was working fine before we left to go camping, I have cleaned and checked everything, as the troubleshooting guide recommends..
  6. LEN

    LEN Senior Member

    Ok maybe not a thermocouple but there is a flam sensor, if it isn't working or is not in the flame it will light for a few then shut off as if there is no flame.

  7. nineoaks2004

    nineoaks2004 Junior Member

    Atwood e-mailed me back, and says it is either the board or the spark electrode.... Thanks
  8. C Nash

    C Nash Senior Member

    Most likely the board. If it was the spark electrode it would not light. Still should have the sensor in the flame to shut off the gas if the flame goes out like Len said.
  9. nineoaks2004

    nineoaks2004 Junior Member

    I am going to take the board up and get it tested..I am going to convert to 110V also, my cousin did it ans it works good for campgrounds.. Thanks
  10. H2H1

    H2H1 Senior Member

    nineoaks are you saying your HWH is gas only? The ones I have seen are gas/ 110 electric. In the really old one they were 3 way,, 12v/gas/110v. I know mine is gas/electric 110v.
  11. nineoaks2004

    nineoaks2004 Junior Member

    It is gas only
  12. LEN

    LEN Senior Member

    Might try just reseating the plg ins on the board, might just be a corrosion issue.

  13. nineoaks2004

    nineoaks2004 Junior Member

    I have tried that too, and everything else the trouble shooting guide told me to do, I am going to take the board to be tested today Thanks
  14. Guest

    Guest Guest

    well i would bet it is the board ,, the gas valve and "unless' the flame sensor is missing ,, it will light ,, but i have seen a few gas valves fail ,, only on a few gas only and a few gas/electric ,, very few 12 volt wh around ,, they were gone in about the 60's,, u said all else works ,, right?? ,, i would also ck the gas flow to the wh ,, u may have a restriction in a line do to a bent line or what ever,, i would ck and see if all gas is at 11inches water column ,, u can buy a tester at the local rv store not really good IMO ,, but it will tell u what is "kinda going on" but agian JMO :) let me know what u find ,, and if the board test ok pm me ,, i will help u thru it ,, i kinda know where the prob is
  15. nineoaks2004

    nineoaks2004 Junior Member

    fixed the problem on the Atwood water heater

    Thanks for all the ideas.
    Thinking back on years of working with DC voltage (lots of this in the old Navy) I did not think I could make things worse so I disassembled the unit, took all the parts into the shop and and cleaned them on a wire wheel. Put it back together and it is working fine now, I figure it must have been a ground problem, I also cleaned all the lugs. Meanwhile I also installed the Camco 110 v conversion for $66.67 from this was really easy to install, now I have a backup and I can have hot water in the campground electricitytoo and save on LP., it is a little slow to heat but at my age I don't get in a hurry anyway I can also lite off the LP heater if hot water is needed fast.
  16. LEN

    LEN Senior Member

    Hey good work and saved a few bucks.

  17. nineoaks2004

    nineoaks2004 Junior Member

    Big problem was the 110v conversion lots of people (my cousin included) said they got it installed in 2-3 hours, it took ME 3 days, of course my bad back and the heat probably contributed to the time delay too.

Share This Page