Front Air Suspension

Discussion in 'Class A / Diesel Pushers' started by ONESBB, May 9, 2010.

  1. ONESBB

    ONESBB New Member

    I just bought a 1999 American Eagle. I am totally new to RV's. I started the RV today and the front air suspension did not raise. I have let it run for about 30 minutes and nothing has changed. I only have about 2 inches of clearance above the front tires. IS there anything I am doing wrong or can check. Any help would be appreciated.
     
  2. Triple E

    Triple E Senior Member

    Re: Front Air Suspension

    Hello SBB. Welcome to the best RV forum on the Web.
    Is your air pressure building up? Should be around 120 to 130 psig. I have two needles on my pressure gauge. One for each tank. If your pressure is there, shut off the engine and crawl under the front and listen for an air leak. You might have a busted line or a crack air fitting. Your rig is eleven years old. Might be a good idea to check all of your air fittings and air lines. Hopefully your air bags are still good. Good luck and let us know what you find. :)
    :8ball:
     
  3. LEN

    LEN Senior Member

    Re: Front Air Suspension

    Might just have a sticky valve. Dump the ai, Lower the jacks, raise the front just a bit then restart and see if the retract of the jacks doesn't cure things.

    LEN
     
  4. ONESBB

    ONESBB New Member

    Re: Front Air Suspension

    Thanks for the reply. We do have air pressure built up and we do n ot hear a leak. The pressure is not dropping on the gauges either, they are steady.
     
  5. Guest

    Guest Guest

    Re: Front Air Suspension

    As len said try raising it up with the jacks ,, u might have a level swtich which is rusted or just plain stuck :)
    Opps btw welcome to the forums
    :approve: :approve:
     

Share This Page