Furance works part time

Discussion in 'General RVing' started by hobo, Nov 15, 2008.

  1. hobo

    hobo New Member

    I have a Atwood Furnace it lights part of the time.The rest of the time it goes into it's cycle
    and doesn't light,after three trys it shuts down.(No air in line and no bugs to be found)
    Has anyone else had this happen?
  2. Johnny-O

    Johnny-O New Member

    Re: Furance works part time

    Check the gap between igniter and burner. Should be about 1/4 in
  3. Kirk

    Kirk Senior Member

    Re: Furance works part time

    It could also be a bad igniter and if that doesn't solve the problem, they it is probably the igniter circuit board. If you replace it, I suggest that you use an ingniter board from Dinosaur Electronics, rather than from the manufacturer. It will cost less, perform better and it has a three year warranty, while the OEM has only one.
  4. hobo

    hobo New Member

    RE: Furance works part time

    Thanks for the informantion I'll give it a try
  5. rjf7g

    rjf7g Senior Member

    Re: Furance works part time

    Sometimes the simplest solutions (like turning on your LP leak detector) can solve seemingly complicated problems. I am not having furnace issues, I am just asking! Is there a good resource somewhere that has pictures of all of these parts labeled? I found a 10 page guide to troubleshooting furnace issues, but without labeled pictures it is pretty useless to me!
  6. utmtman

    utmtman Senior Member

    Re: Furance works part time

    Mine does the same thing. I unhook the connectors and clean them and hook them up and it will work once. I am sure the circuit board on mine is the problem. I do have the electric side working just fine its only the propane side that does not work. Plan to have it look at in Dec while traveling across Az.

Share This Page