Furnace Won't Stay On

Discussion in 'Talkback' started by ARCHER, Jan 2, 2012.


    ARCHER Senior Member

    Hey everybody, need some guidance. I tried my trailer furnace for the first time this winter (in Florida). The fan comes on, the furnace tries to light about three times then locks out until I turn the thermostat off and back on to heat, then it does it again. Will not stay running. it did this a little bit last winter but finally worked ok. Won't work this time.
    What do you think it might be? How do you fix it? Remember, I am not the smartest cookie on the sheet so simple instructions might go a long way. tks to whomever responds. BTW, I do have a couple small 1500 watt electric space heaters that are woking just fine, but still would like to get the furnace working the way it is suppose too.
  2. LEN

    LEN Senior Member

    When I shut the gas off for a time then restart it takes a number of the 3 start and your out cycles before it restarts. Light stove and water heater for a few then try the furnace for a few cycles.


    ARCHER Senior Member

    Len, tks for the info. We have been using the stove for three months, no problems. We use electric on the hot water tank, but it will light for lp, if needed. it is just the furnace, that will not stay lit. I tried the start at least 9 times and it will lite, but will not stay on to run. Any other ideas?? Sail switch?? Temp switch??>
  4. TexasClodhopper

    TexasClodhopper Senior Member

    Archer, when mine did that, it just needed a good "dusting" around the burner, however you have to find out whether you are actually getting gas to come out of the fire end of the valve and whether there is actually a spark there to light the gas.

    The orifice could be stopped up or the internals of the valve itself could be stuck from sitting around or there could be a spider web shorting out the spark. I have problems from dirt dauber wasps every year.

    More info please!

    ARCHER Senior Member

    Tex, tks. I probably need to remove the furnace, clean all the stuff and try again. When I put duo-therm on furnace, turn temp up to make it come on, it will start fan (to clear out any residual lp), will lite but will then go out after about 4-6 seconds, then fan stays on, will do it about three times, then locks out and fan will then stop. It does lite, but will just not stay lit to actually work like it should. I have plenty of LP, battery is fine (on 120 at site). Might be the sail switch stuck or like you said, dirty or corroded. I have never taken a furnace out of a rv or tt. I guess I would need to disconnect lp, disconnect electrical and then just slide it out and start cleaning, right?
  6. akjimny

    akjimny Senior Member

    Archer - Sounds like it could be a bad thermocouple not allowing the gas valve solenoid to stay open.
  7. H2H1

    H2H1 Senior Member

    Hey Archer, that sounds just like my refri when I was using it in propane a few years ago at the race track. I like Tex had to do a good cleaning of the orifice. I took a old tooth brush and did a good cleaning and then I vacc all the residual out. No more problems.
  8. LEN

    LEN Senior Member

    Also reseat the wires on the control board at the furnace. Next would be the thermocouple like Jim stated, a good cleaning could be the need also.


    ARCHER Senior Member

    Do you have to take the furnace out to clean the thermocouple? How about the sail switch? I have a compressor that I can blow air in pretty easy, but just need to know if I must remove the furnace to do that....
  10. ARCHER

    ARCHER Senior Member

    Hey everybody, I sent an email to Atwood yesterday from their web site and they answered already (fast service). They said it was probably the ELECTRODE that is bad that shuts down the LP flow. Now, i just need to figure out where it is and how to get to get. Anybody know????? The cold front is passing as of today here in Sunny Florida, so i have some time to work on it before the next cold front blows in from the North. I hope I don't have to take it all apart to replace the electrode. tks for all the help
    BTW, I was looking at the schmatic for the furnace, and I don't see any reference to a Thermocouple.
  11. wildcatervin

    wildcatervin Member

  12. Grandview Trailer Sa

    Grandview Trailer Sa Senior Member

    Atwood very well could be right, but we don't see many bad electrodes. You will have to remove the furnace to get to the electrode, and what I think is wrong. I think it is dirt or a blockage at the gas nozzle right where it fires. We had one doing pretty much the same thing last week and we had to take it down and clean the nozzle. Problem is, if you have never done it, it could be a challenge.

    You also MUST have proper voltage off the battery and you MUST have proper LP gas pressure. (Your stove can work with low pressure, but the furnace won't)

    Also: Furnaces do not have thermocouples. A bad sail switch won't let the gas valve open, so it won't burn with a bad one

Share This Page