New Batteries - No response from engine

Discussion in 'Class A / Diesel Pushers' started by beachboy, Jan 31, 2009.

  1. beachboy

    beachboy New Member

    Replaced engine batteries and dash lights up when I turn the key, but engine doesn't turn over. I hear a click in the dash, but no response.
    1998 Beaver Monterey DP
    300 Cat, 6spd Allison
    Would there be something click off when I took out the old batteries?
     
  2. Guest

    Guest Guest

    RE: New Batteries - No response from engine

    i would ck the grounds ,, at the batts ,, and on the frame ,, also ck the starter connection also ,,, also move u'r trans selctor a few times ,, and see what happens ,,, u could have a bad starter also ,, but let us know back :approve: :approve:
     
  3. LEN

    LEN Senior Member

    Re: New Batteries - No response from engine

    Are the new batteries fully charged? If so you could have a bad battery but I would think it would start on one hot one.
    Recheck cables is the only thing I can add.

    LEN
     
  4. webb

    webb New Member

    RE: New Batteries - No response from engine

    have you resolved your problem. I can't help you but I have what sounds like the same problem with my motorhome so I'd be anxious to know what's happened for you.

    thanks

    cliff
     
  5. beachboy

    beachboy New Member

    Re: New Batteries - No response from engine

    Rechecked all connections today and still no go. There looks like what I think is a solenoid in the compartment, and when I push the start, I hear a click from it, but nothing happens.
     
  6. LEN

    LEN Senior Member

    Re: New Batteries - No response from engine

    Have you tried the emergency start switch to add the coach batteries. If it turns then you have either a weak solenoid, bad connection/s to the start batteries or a bad starter. Also what does your volt meter look like? With mine when the pre heat is on things drop to about 10 volts. That air heater really take the juice. There is a fuse on the rail in the motor compartment near the starter that I have read about(never seen) would be on battery side, maybe follow wires to it. That would explain good battery but no turn over to start.

    LEN
     
  7. dbarton291

    dbarton291 Senior Member

    Re: New Batteries - No response from engine

    Does the transmission selector light up?
     
  8. beachboy

    beachboy New Member

    Re: New Batteries - No response from engine

    1. Yes the transmission selector lights up.
    2.Does not turn with emergency start.
    3. Volt meter shows about 10 volts.
     
  9. dbarton291

    dbarton291 Senior Member

    Re: New Batteries - No response from engine

    If that's your starter solenoid you hear clicking, likely culprits are the solenoid not getting adequate voltage or the starter itself. Hard to be 100% sure without checking out the neutral start circuitry properly.
     
  10. Guest

    Guest Guest

    Re: New Batteries - No response from engine

    10 volts is not enough to turn over the engine ,, how long have the batts been in ???? and are they good quality ones ,, and have u load tested them ,, i know u said they were new ,, but if u look on the battery ,, there should be a engraved 7 or 8 digit number and letters ,, if so let us know ,, u may have some out of date batts ,, and also ck the batts ,, with an volt ohm meter ,, at the batt's them self ,, and let us know what that says ,, :approve:
    Also ck the house batts ,, u use them for the emergency start ,,, but u may have further probs ,, as dbarton said ,, my have a selenoid bad
     
  11. beachboy

    beachboy New Member

    Re: New Batteries - No response from engine

    Embarassing to say the least, but in changing the batteries a cable was not connected. Took a diesel mechanic about 15 minutes to track this down, and when he got everything in order, she fired up on the first turn.
     
  12. *scooter*

    *scooter* Senior Member

    Re: New Batteries - No response from engine

    Sorry to hear it took a mechanic, but really glad it was just an overlooked connection. ;) :)
     

Share This Page