No 120 Voltage.

Discussion in 'General RVing' started by 101344badger, Sep 6, 2011.

  1. 101344badger

    101344badger Junior Member

    Last Sunday we had a power outage in the house so went to use the RV for breakfast. We were the microwave and the electric waffle iron when my wife pushed the button for the coffee make. Immediately, no juice. I have checked all breakers I can find, they all check out ok. My RV is a 1999 Newmar Dutch Star, diesel pusher. The generator runs on propane. Any ideas as to what may be the problem? Thanks.
  2. bandalop

    bandalop Member

    When you said you checked all the breakers you could find, did that include the one at the generator?
  3. TexasClodhopper

    TexasClodhopper Senior Member

    Did you include checking any GFIC's that might be tripped?
  4. LEN

    LEN Senior Member

    ...check the breakers on the converter/inverter, there are usually 2, 20amp.

  5. 6dinkydow1

    6dinkydow1 Junior Member

    I have the same problem, my converter (WFCO 45a ) doesen't seem to have a breaker. It does have two 30a fuses. A little history first. About a month ago I started up my generater and turned on the AC and tried the outlets, NO 120v POWER, after resetting the gen breaker still no power. I then found two 30a fuses on the converter box, both were blown. I replaced them and everything worked, I kept checking the converter box and it did get a little warm but nothing to alarm me. Fast forward to yesterday. I started the gen, NO 120v POWER. The gen breaker was reset, checked all fuses in the breaker box and on the converter box, all are ok, reset all GFCI outlets, still no power. Could I have another breaker I don't know about or is my converter shot? My converter box and breaker box are under the sofa. Also, I have 120v power with the shore cable plugged in and the converter box seems to be working then because the fan runs ( the fan does not run when trying to use gen power).
  6. TexasClodhopper

    TexasClodhopper Senior Member

    Considering that everything works on shore power then there's no use checking fuses. I'd be looking for/at the "AC transfer switch" to see if there's a problem there. There's a relay in there that could have burned contacts. With burned contacts the relay could be intermittent for a while before they actually just give up.
  7. 6dinkydow1

    6dinkydow1 Junior Member

    Thanks for the reply Clodhopper. I went back out last night after giving up on it yesterday and checked everything again. After two days of searching for a hidden breaker, blown fuse, or a loose wire I finally remembered to disconnect the shore cable from the garage and plug it back into the RV when the gen is running :stupid:, :blush:.
  8. TexasClodhopper

    TexasClodhopper Senior Member

    I made an assumption about what RV you had. Mine is like yours. I have to transfer the plug myself, too. Good you got it fixed.

    PS. Ya doesn't have to call me "Clodhopper", but ya can call me "Tex!" :triumphant: (Maybe you remember the old LAUGHIN TV program way long time ago....)
  9. brodavid

    brodavid Senior Member

    Good job Tex
  10. 6dinkydow1

    6dinkydow1 Junior Member

    Tex, I have a 2008 Fleetwood Tioga Ranger we bought March 2011 :D. Thanks to all you guys on this forum who helped me while I was setting up the MKX to pull behind us :applause:. We leave tomorrow for our maden journey with a toad. Short trip, only three hours there but it's where my wife wanted to go. I would have liked to have taken it for a short test run first to make sure everything worked. I got behind yesterday when I broke my passenger side mirror and had to drive 240 miles roundtrip to get another one cut :stupid:.

Share This Page