Odd Problem with my Atwood Water Heater

Discussion in 'General RVing' started by KSagal, Jul 14, 2008.

  1. KSagal

    KSagal New Member

    I am wondering if anyone has any advice about my water heater problem...

    I just used a new-to-me Jayco 1206 popup camper, 1998 I think. It worked great but the water heater has an odd problem.

    It has an older style 6 gallon heater with a pilot light.

    I light the pilot light as I should. Within a minute on prime it stays on like it should.

    I turn the unit to 'on' and the main burner comes on like it should.

    It runs for 3 to 4 minutes, then there is a click in the control valve, and the whole unit goes out, both main burner and the pilot light.

    I can turn the controls back to 'pilot' and light the pilot again, and then go back to 'on' and it works, again, for only 3 or 4 minutes.

    One time the pilot stayed on, and the burner came off, I ran the hot water till the burner came back on, but then when the burner went off, it took the pilot with it...

    I am guessing that instead of turning off the burner, all the gas is going off, or there is too much draft, and the pilot flame is being sucked into the tube with the main burner, and the temperature sensor is cooling down, or something else.

    Does anyone have any suggestions?
  2. Grandview Trailer Sa

    Grandview Trailer Sa Senior Member

    Re: Odd Problem with my Atwood Water Heater

    For one thing, make sure there is water in the heater. If so, sounds like thermostat problems to me. That means replacing the approx. 4" square control valve body.

    Good Luck
  3. KSagal

    KSagal New Member

    Re: Odd Problem with my Atwood Water Heater

    Thanks for the thoughts. I was figuring it was in that unit (since there is not much else)... Yes, there is water in the unit, and it does warm up. The previous owner meant well, but must have had stock in anti freeze companies, because instead of bypassing the heater, it was full of antifreeze. It was hooked up to city water at the time, and was full of water.

    This unit has a small metal lever on the tank side (far side from the outside access door) that is unmarked, but I am guessing is a temperature adjustment. I was wondering if it was involved.
  4. Kirk

    Kirk Senior Member

    Re: Odd Problem with my Atwood Water Heater

    The Atwood water heaters which have a pilot use either of two control valves, one from White-Rodgers and the other from Robert Shaw. The White-Rodgers will have a single knob on the side and a lever while the Robert Shaw has a knob and a smaller knob, located on the top. Both of these use a heat sensing bulb that sends a very small current back to the control valve which keeps the valve open. The reason that you have to hold the button down to get the pilot lighted is to allow that device to heat up and supply that signal. To me, it sounds as though that sensor is failing. They are not difficult to replace and you can locate it by looking into the burner area as it will be located directly in the flame of the pilot. It can be removed and cleaned. You can trace the connection back from that sensor to the control valve and remove the connection there, clean it and make sure that it is tight.

    If I remember correctly, they both use a connection with a threaded nut to connect to the bottom of the control valve, but it has been some time since I last worked with one of the pilot models so trace it to be sure and don't trust my memory. It should not be very expensive to get a replacement for it and that is the most likely cause of your problem, although the control valve could be also. While you are about it, you may want to replace the ECO as well, just to be sure.

    If you have the White-Rodgers control valve it had a temperature knob to the left of the pilot/on knob.

    If you wish to send me an email address, by private message, I have some some service documentation for the Atwood, although it isn't really great. I would be happy to send what I have if you think that it may help.
  5. KSagal

    KSagal New Member

    Re: Odd Problem with my Atwood Water Heater

    Thanks for the info.

    It is indeed a White-Rogers with the lever and the one large blue knob.

    I too was wondering about that temperature sensor. It is covered in soot. I was also considering the pilot itself. It seems to be weak to me, mostly yellow as if not enough gas or not the right gas air mixture. I see what looks like a small breather hole right at the end of the supply tube that feeds the pilot assembly itself.

    Both small aluminum tubes (pilot supply and temperature sensor return) do indeed thread into the bottom of the unit as you recalled. I will remove both and clean both, and re-assemble. I am teaching myself more about these things than I had originally intended. It is interesting...

    Thank you very much for the assistance, and your offer of data... You have a PM.
  6. Kirk

    Kirk Senior Member

    Re: Odd Problem with my Atwood Water Heater

    Since I sent the copy of the service information, reading your post it does sound as though the air mix is not right. I suspect that for the pilot there is no adjustment which makes me think that it is dirty and partially blocked with bug nests or such. For some reason bugs seem to be attracted to the odor of propane. (I have stainless steel bug screens on both of my furnaces and the water heater.)

    When things are proper the flame from your pilot should be mostly blue with just a tip of yellow. The flame from the burner when water is heating should also be mostly blue, but with multiple touches of yellow. Completely blue in either case means too much air for the propane. Mostly or all yellow means too little air mix. The soot tends to support the belief that you are not getting enough air, or it could even be propane pressure that is too high.

    If it gets to that point, have your propane pressure checked by an RV tech. It should be 11" of water column, as measured by manometer at the inlet to the water heater. Propane pressure regulators do fail, but rarely to the high pressure side.
  7. KSagal

    KSagal New Member

    RE: Odd Problem with my Atwood Water Heater

    It turns out that there was too weak a pilot, and it was getting blown out by the back draft of the the main burner going out...

    I took the pilot supply tube off, blew it out, and more importantly, did my universal fix... I took a fine wire and poked it into all the breather holes I could find! There is a small one in the fitting at the pilot flame end of the supply tube fitting...

    The pilot went from mostly yellow, to mostly blue, and then the whole system started working properly...

    THANK YOU very much to the respondents, and especially to Kirk for the manual. It is a bit too generic to help for this one, but it will be a good document for the archives...

    By the way, the wire in all those tiny holes is a trick that I learned when repairing small carborators in tiny gasoline engines, like lawn mowers and chippers... Gunk in tiny places is often the problem regardless the symptom, or device.

    Thanks again everyone...

Share This Page