@ Problems

Discussion in 'General RVing' started by wildcatervin, Aug 2, 2013.

  1. wildcatervin

    wildcatervin Member

    1. Went out to the RV to put the covers on the tires and the jacks will not go down.When I hit the jack button all the lights flash on the control panel.Checked the fuses and breakers on the outside where they are and all is good.Tried to contact Damon who makes the couch ,waited 25 min and nothing.Maybe someone here can help why it doesn't work,yesterday they went down ok.This is a 2010 Damon Astoria,38 ft.Next problem is the inside stinks like toilet.New wind vents on the top,Filled tank with water and bleach,drove around the country and still smells terrible.When I left the camp ground last flushed it 5 times to clean it out.Think maybe I should of stayed in bed today.Thanks for any help.
     
  2. H2H1

    H2H1 Senior Member

    I don't know about your Damon, but my South wind by Fleetwood will not operate unless the emergency brakes are applied. I hope this is your problem. post back what you find out what was the problem
     
  3. wildcatervin

    wildcatervin Member

    Hollis,dint go back to the RV after all this happened,sometimes it is best to walk away and try it later.The break is set all slideouts are in.The thing that bothers me is the control panels lights are flashing.Be nice if I could contact a rep,but we know how that works.Hate to put it in the shop if it is something simple,(RV simple,no).
     
  4. LEN

    LEN Senior Member

    Are you batteries up, also you may need to start the MT. Kill ALL 12 power to the MH both house and motor. This should cause a reset to all systems. If this doesn't work look at the manual for the jacks and there should be a reset or reboot for the panel. Also look for a wire that maybe loose or unplugged from the controller. Look at fluid level if they are not electric. Then if all else fails call the brand of jacks people direct, they usually have a shorter answer. As to the stinkie problem, make sure all the sink traps have water in them this includes the tub shower. Check the under the sinks there is a valve that can get stuck open ( vacuum breaker valve).

    LEN
     
  5. wildcatervin

    wildcatervin Member

    Thanks Len,btrys are ok,have to start the MH to make the jacks work,will try the btry kill bit,dont have a manual for the jacks,might find one online,will check the controller,fluid is good,and they are electric so atleast the motor should run if the fluid is low,will have to call Damon who makes the jacks.As for the stinky problem,maybe when I had the slides out a squirrel might have gotten in there and died,had this happen once when I was putting in a window unit,took a month to get rid of the smell.Cant look in the slide out area as it is sealed ,but a varmit could get in.Will let you all know if I have any luck.
     
  6. wildcatervin

    wildcatervin Member

    Ok,so far I have erased all of the codes by holding down all 4 center buttons at once,cleared it but still no jacks.Keeps reading that jacks are not up,went and looked and they all seam up.Went to there web site and it looks like there is a inline fuze that I have to find,it is supposed to be close to the unit,will look tomorrow.If the motor is blown we are looking at 1200 just for the motor.Contacted the company to see how long the warrant is good for,waiting for a answer.
     
  7. wildcatervin

    wildcatervin Member

    By the way it is a Lippert LCI System.
     
  8. wildcatervin

    wildcatervin Member

    Well found the fuze and it looks ok,will wait and talk to Lippert tomorrow and see what they think.Guess I might bite the bullet as the warrenty on these things,for the price is not very long.Cant understand this as the average auto gets 3 to 5 yrs and a RV gets a year except the chassis,which is 5.But gees for the price you would think it would be better.
     
  9. H2H1

    H2H1 Senior Member

    you would think we would a better warranty for what we have to pay for these things.
     
  10. wildcatervin

    wildcatervin Member

    Cotacted Lippert and talked to the tech,(what a grouch he was)maybe a bad Monday.1yr warrant is all and he did give me1 tip.Will try it later.
     
  11. wildcatervin

    wildcatervin Member

    Okay here is the latest on the jack problem.Mechanic took the system down and the motor on the pump was full of fluid,leaking from the pump.I thought I would end up buying a new motor,took it apart and cleaned it up and it runs great ($400.00) maybe saved.Talked to the Lippert rep and he said I needed the short shaft with O rings on it.It goes between the motor and the pump and is about 1.5 in long.The new 1 came and it is different from my old 1.It is larger and has 2 O rings on it to stop the oil from getting to the motor,my old one had no O rings or a place to put them.Called the tech back and he checked and said this was the right part.My ? is if this is the right part,which looks like it will solve the problem,why wasn't this kind used in the first place?Of course the tech had no idea if this was a modification or not.Probly is and Lippert doesn't want to admit it as it could cause them money for a recall.So if anyone has a problem in this area(these are used on many coaches)Would like to know if any of our readers had this problem and I would be able to talk to the manufactor.Sorry for the long post,hope it would help someone.
     
  12. Shorty

    Shorty Senior Member

    Concerning the smell...in my coach sometimes it's the gray water. To get rid if the smell within 10 min I pour about 1 cup of vinegar down any drain. This normally happens after we get back and my bride cleans up the inside so it's ready for the next trip and the gray water sits in the tank...then just when you move the coach, that stink comes. I am sure that a vent needs my attention, but this is very rare.
    Also, one time I had a fungus in my fresh water tank...didn't smell it until the coach heated the hot water as I drove...remedy for that was to flush the fresh water tank
    My 2 cents anyway
     
  13. wildcatervin

    wildcatervin Member

    Problems

    This is the item that I replaced on my jack pump.Can anyone see the difference,the tech said they were the same ,except this is a new upgrade.One heck of a upgrade.The one on the left is the old parts and the other in the plastic is the replacement.
     

    Attached Files:

Share This Page