slides won't go out

Discussion in 'Towables' started by d69zcam, Jun 4, 2010.

  1. d69zcam

    d69zcam New Member

    My slides worked perfectly yesterday evening. The 5th wheel is sitting in front of my house. When I went out this morning, 8 hrs. later, nothing, they wouldn't move!! I checked the fuses w/a tester, all ok, the circut breakers had none that were tripped. Then I checked the slide panel, all the wires had power, again checking w/the tester. I used a wire to jump over the switch hoping that would give power to the slide, nothing. I did hear a clicking sound and traced it to the relay in behind the front storage door and thought, I found the problem. It is a Ford relay, so, I went to Ford and got a new one. I plugged it in hoping that I found the problem, again, nothing, just a clicking sound again!! I just bought this 5th wheel from a private owener five weeks ago and am finding issues with it, but nothing that can't be fixed. It is a 31' Sea Breeze, model 2031. The batteries are charged very good. All the lights are bright in the unit. I am thinking whatever the relay drives, that may be it, but what? Can someone give me some help, please!! Thank you, D.
  2. LEN

    LEN Senior Member

    Re: slides won't go out

    Check your grounds if you have power and the relay is working then you may have a faulty ground.

  3. Triple E

    Triple E Senior Member

    Re: slides won't go out

    Question: How many slides do you have and do they all work off of one switch? Also, are the slides in or out? :question: :question: :question: :question:
  4. Winston

    Winston New Member

    Re: slides won't go out

    On my R-Vision, the battery must be charged for the slide out to work, even when using the 110 v hook up.

Share This Page