Suburan furnace 13,000-17,000 BTU

Discussion in 'Beginning RVing' started by gloriacope, Oct 25, 2008.

  1. gloriacope

    gloriacope New Member

    Hi,We just got a 1996 Rexhall Motor Home WDBY 35 and we have been going over everything in it and we got everything up and going but the furnace. We have no books that came with it. The gas is on and the blowers come on but no heat. We have checked to see if we have a flame no we don't. We know the gas is on because the stove comes on.

    Any suggestion?

  2. Guest

    Guest Guest

    RE: Suburan furnace 13,000-17,000 BTU

    first of all welcome to the forums ,, i have an idea u might try
    turn the heat on at the thermo ,, set it above the temp outside .. the fan should run ,,, let it run for about 30 mins or so ,, set the thermo at a lower setting ,, and let the fan go off ,, then swtich the unit off agian ,,, let it sit for about 30 to 45 seconds ,,, turn the thermo back on ,, and set the stat at a warmer temp ,, it should kick by then ,, since u said the stove works ,, then u should have all the air out of the system ,, and also be sure the LP is on ,,, i have to do this to my own furnace when i ck it or start for the first time ,, try it ,, and let us know what happens :approve: :approve: :approve: :)
  3. Pancanbob

    Pancanbob Senior Member

  4. miket

    miket New Member

    RE: Suburban furnace 13,000-17,000 BTU

    Check your DC voltage at the furnace, needs to be above 10.5 for the blower (fan) to run fast enough to satisfy the sail switch.

Share This Page