Sway Bar - Front

Discussion in 'General RVing' started by sepisllib, Oct 26, 2004.

  1. sepisllib

    sepisllib New Member

    Servicing unit - I discovered the front sway bar has a broken mounting bolt - on driver side of front axle.

    This is an Eaton axle - Spartin Class A 26000 gvr mountain home chassis.

    Spartin claims they did not install the sway bar as part of their supplying the chassis to Gulfstream.

    Gulfstream claims that Spartin did install the sway bar and they did not.

    All I need is the eye bolt, metal washer on top of the top bushing, the top bushing and bottom bushing, the metal bottom washer, nut and some sweat to install it.

    This is one large sway bar - nearly 2 inches in diameter.

    Anyone out there having experience locating parts like this?

    Bill
     
  2. Gary B

    Gary B Senior Member

    Sway Bar - Front

    Hi Bill, maybe if both Spartin & Gulfstream say they didn't install the sway bar, then a previous owner did it aftermarket, you could check with IPD or Helwig and see if one of their kits. Heres a couple of site don't know if they'll be any help. www.ericsrv.com
    www.hellwigproducts.com also if you do a google search motorhome swaybars you may find more imformation. Good luck finding the parts.
    :) :laugh: :cool: :bleh: ;) :approve:
     
  3. sepisllib

    sepisllib New Member

    Sway Bar - Front

    Thank you for the help. I did try the search, however only came away with the usual RV info. Nothing big enough for my rig.

    I was finally able to reach a customer care representative at Spartan that knew what I was talking about and they indeed did install that on the chassis prior to shipping to Gulfstream. The parts I need are on the way.

    I kept the sites you mentioned too - never know what may help down the road.

    Thank you again. Bill

    [​IMG]
     
  4. Gary B

    Gary B Senior Member

    Sway Bar - Front

    Hi Bill glad you are getting your parts, sometimes its furstrating when they tell you no we didn't install xyz and then you finally get the right person and its oh yea we installed them. :eek: . Good thing is hepl is on it way :laugh: . The Erics RV site has some interesting and good imformation, I've refered to it several times. Did you get the idle thing worked out yet?
    :) :laugh: :cool: :bleh: ;) :approve:
     
  5. sepisllib

    sepisllib New Member

    Sway Bar - Front

    Not yet - but I believe communication with cummings will solve it. Not sure - but I think I have a Potentiometer type unit at the pedal in the front and the voltage is sensed to adjust the throttle at the engine. Problem could be in either - or both - ends.

    Working on and thank you again for the suggestions. Resources and friends are what makes things like this easier.

    Bill
     

Share This Page