turn signals problem

Discussion in 'General RVing' started by fordman01, Jun 25, 2011.

  1. fordman01

    fordman01 New Member

    We picked up our 2003 class c coachman with E450 ford and thought we had checked everything and when i was on the road the wife tells me the turn lights are not working.there are many books and manuals with it but the ford owners manual is missing,wondering which fuse panel it is in,if that's the problem.
     
  2. H2H1

    H2H1 Senior Member

    Re: turn signals problem

    I don't know actually but sounds like the fuse panel would be in cab of the vehicle. I know Jenny and Randy (trytofindus) has the same unit. I hope they look in on the forum and see your post and can give you some insight.
     
  3. fordman01

    fordman01 New Member

    Re: turn signals problem

    Thanks,there's a small panel under the dash and they are numbered but i don't have a diagram as to which covers what,there's also a larger panel under the hood.
     
  4. Triple E

    Triple E Senior Member

    Re: turn signals problem

    Look just up and to the right of your emergency brake.
     
  5. H2H1

    H2H1 Senior Member

    Re: turn signals problem

    then get a fuse tester from any auto part store so you can test each one in place. They do come in handy, as it can also pull the fuse out. And since it is a multiple tool, the Government will pay big bucks for it :laugh: :laugh:
     
  6. try2findus

    try2findus Senior Member

    Re: turn signals problem

    Hello all. Yes, our Jayco Greyhawk has an E-450 and our fuse box is located under the dash by the emergency brake area. I have a picture somewhere. If needed, let me know and I will try to take a photo of it and post it, but you should be able to Google it.

    Hope you get those turn signals working and we'll see you somewhere along the way!

    I'll be glad to copy and email you the pages that list the fuses if you need it. Let us know! :)
     
  7. dfedora

    dfedora Member

    RE: turn signals problem


    Denny

    I have a 2005 RV that is on a 2004 Ford E- 450 chassis . Turn signal fuse, is fuse #7 10 amp 2nd row down from top 2nd fuse from the left. located as everyone stated to the right of emergency brake. Hope this helps.
     
  8. fordman01

    fordman01 New Member

    Re: turn signals problem

    Thank for your help Dick,i'll check it out.
     
  9. fordman01

    fordman01 New Member

    Re: turn signals problem

    Dick you were right on target,burn out fuse and they work fine now,thanks again.
     
  10. try2findus

    try2findus Senior Member

    Re: turn signals problem

    So glad your problem is resolved!

    Isn't the RVUSA Forum the BEST???!! :) :) :)
     
  11. dfedora

    dfedora Member

    RE: turn signals problem


    Great news glad to help. :)
     

Share This Page