Allison MD3060R

#1
I'm new to motorhome world and just bought a used '96 300hp 8.3cummins, MD3060R, with 85000 miles.

1. There is a slight delay (~1-2 sec) on upshift from 3 to 4. Normal all other shifts up or down. It will shift out of 3rd and pause 1-2 sec before 4th engages. When 4th engages it is firm and no evidence of slippage in any gear. Fluid looks and smells good.

2. I am going to change fluid & filters before we take a trip. Is there any way to tell if it has transynde?

3. Also, the lock-up doesn't seem to stay on at highway speeds. At 60-65 mph in 6th gear, I notice that engine RPM will flucuate when we go up a slight hill or overpass.

4. The engine has a Jacobs E-Brake and the Allison service dept. told me that the retarder tranmissions did not preselect. What is the best solution?

Thanks for your input.
Jim
 
#2
Allison MD3060R

Jim,

I'm not an expert on this but I know some of what you ask because I have a MD3060P in my Tourmaster.

If it was me, I'd change the fluid and filters first. I had to order the filters directly from Allison as I couldn't find them anywhere else.

If the fluid is sort of reddish then it's Dextron III. Transynd is totally different – clear in color. My coach is a '93 so I'm not going to switch to transynd now.

The next thing I'd do is check your TPS sensor cable attachment. On mine, if I lift the bed, I can see the throttle linkage just fine and right beside the throttle cable is another cable connected to the same point and it runs over to a box on the chassis. That connection right by the throttle is what comes loose. On mine, the pin on the cable just wore almost in two and slipped right off. When the cable is off, the transmission will shift up and down roughly - very roughly sometimes.

I know nothing about the other items - sorry.

Cheers,
Dennis

'93 Tourmaster
Jeep Overland toad

quote:Originally posted by jadcadfarm

I'm new to motorhome world and just bought a used '96 300hp 8.3cummins, MD3060R, with 85000 miles.

1. There is a slight delay (~1-2 sec) on upshift from 3 to 4. Normal all other shifts up or down. It will shift out of 3rd and pause 1-2 sec before 4th engages. When 4th engages it is firm and no evidence of slippage in any gear. Fluid looks and smells good.

2. I am going to change fluid & filters before we take a trip. Is there any way to tell if it has transynde?

3. Also, the lock-up doesn't seem to stay on at highway speeds. At 60-65 mph in 6th gear, I notice that engine RPM will flucuate when we go up a slight hill or overpass.

4. The engine has a Jacobs E-Brake and the Allison service dept. told me that the retarder tranmissions did not preselect. What is the best solution?

Thanks for your input.
Jim
 
#3
Allison MD3060R

If you want Allison filters for about half pricr contact Inland Truck Parts. They are in the back of FMCA. Great price and Allison filters
 
Top