md 3060 p blank touch pad (no power)

#1
After adding 3 foot of wire to relocate the touch pad and plugging it back in I have no power to the pad. I have tried the ECU, relay module and the shift pad in an other vehicle and all work fine.It does have power to the relay module but seems to have none to the ecu. Can anyone help.
Thanks :(
 

Kirk

Senior Member
#2
md 3060 p blank touch pad (no power)

If it worked before you moved it, I would look to the modification. I would start by checking for continuity of each wire from the old location to the new one. Be sure that you have a good accurate meter to make the checks. And look very closely at the connections where you patched into the origional wires.
 

hertig

Senior Member
#4
md 3060 p blank touch pad (no power)

Have you checked the ground? Perhaps the previous mounting was grounded and the new one is not?
 
#5
md 3060 p blank touch pad (no power)

Did you use butt connectors when adding your wire? If so, when you are doing your continuity checks it may check out ok until you put an electrical load on it. I always recomend replacing the whole wire and put new terminals in the connector. If you must use butt conectors get a good solid wire crimper.
 
#6
md 3060 p blank touch pad (no power)

Did you use butt connectors when adding your wire? If so, when you are doing your continuity checks it may check out ok until you put an electrical load on it. I always recomend replacing the whole wire and put new terminals in the connector. If you must use butt conectors get a good solid wire crimper.
 
Top