2007 playmor power issues

Discussion in 'Beginning RVing' started by brayden1019, Apr 18, 2010.

  1. brayden1019

    brayden1019 New Member

    i recently purchased a 2007 playmor camper, my question is this. it has a 12volt battery and the 120v power cord, is the a switch to go between the two power sources. i charged the battery to full charge and still cant get any power to the radio or other appliances. not sure what i am doing wrong, please help
     
  2. C Nash

    C Nash Senior Member

    Re: 2007 playmor power issues

    Welcome to the forum. Not familar with the playmore but some have a cut off switch. Ck for blown fuse. Will 12 volt lights work?
     
  3. brayden1019

    brayden1019 New Member

    Re: 2007 playmor power issues

    i can't get any of the lights or anything to work, there is a switch on the outside of the camper but it seems to have something to do with the battery and charging the battery. it says on the switch to turn off engine before turning off switch
     
  4. brayden1019

    brayden1019 New Member

    Re: 2007 playmor power issues

    got it figured out had a bad connection to the battery, thanks to all of u who look at my question
     
  5. Kirk

    Kirk Senior Member

    Re: 2007 playmor power issues

    Glad to hear that you got things working.

    Keep in mind that your appliances and the lights all use 12V-dc power in order to be able to use the RV with no 120V power.

    And welcome to the forums! Do stay around and become an active part of the group.
     

Share This Page