a/c does not work on 1999 beaver marquis

Discussion in 'Class A / Diesel Pushers' started by tet1968, Jul 8, 2011.

  1. tet1968

    tet1968 New Member

    One unit was cooling while the other was not. Both fans and compressors worked. As of an hour ago, nothing at all happens when a/c is turned on. Checked the circuit breakers, no luck. Help!
    Don
     
  2. vanole

    vanole Senior Member

    Re: a/c does not work on 1999 beaver marquis

    tet1968,

    Do you have the 4 button Duotherm Comfort Contro System? If so go here to page 7 and try the reset procedure http://bryantrv.com/docs2/docs/ccc4.pdf

    Also if you have the 4 button system you might want to take the termostat off the wall and remove the flat phone cable and check to see if it has a huge dust bunny at the connection. If so blow it out with some canned air like you would a computer keyboard.

    Jeff
    GO NAVY
    Fly Navy
     
  3. tet1968

    tet1968 New Member

    Re: a/c does not work on 1999 beaver marquis

    Thanks Jeff, I got the system to run, but only the back unit kicks out cold air. I am taking it in to be checked over Monday. We just purchased and I want to make sure all systems are in good condition before we set sail.
     
  4. vanole

    vanole Senior Member

    Re: a/c does not work on 1999 beaver marquis

    tet1968,

    Good luck when taking it in. Hopefully its a quick fix. BTW the Marquis is a great coach.

    Jeff
     
  5. H2H1

    H2H1 Senior Member

    Re: a/c does not work on 1999 beaver marquis

    Hey Don, does your sign in name mean tet offence in Viet nam 1968? IF so I was there in 69
     

Share This Page