Allison 3060 shift pad not lighting or shifting

Discussion in 'General RVing' started by fredhengel, Dec 31, 2006.

  1. fredhengel

    fredhengel New Member

    I have a 94 Monaco Dynasty with 205,000 miles with the original MD3060 transmission and ECU that has been working fine until now. After backing about 50 feet the shift display went blank and the Trans went into neutral and would not shift, the Do Not Shift light on the dash lit up also. The battery checks OK, the inline fuse at the battery to the ECU is OK. The fuse in the VIM is OK. The shift pad lights momentarily after turning ignition key and then fades away blinking ,in very few seconds. The longer I wait between tries the longer the shift pad will stay lit up to maybe 30 seconds max. It does not matter if I start the engine or just turn to ON it acts the same. The leveling jacks receive power from the same relay that comes from the ECU and goes into the VIM. The jacks acted the same way the night before the shift pad quit, Power for a second or two then dead. I jumped power from the relay going into the VIM to the jack control and they work fine now. I was able to move the coach about 30 feet after not trying the ignition for a few hours while I replaced a relay and a solenoid that I thought could be the cause, Wrong !

    To move the coach off the street I punched drive as soon as I turned the key, the keypad lit and I was able to drive until it went blank and returned to neutral.

    I obtained a Allison WTEC II electronic controls troubleshooting manual and found how to check codes.
    My Codes are D 1 - 6 9 - 32 and the manual says, I think, replace ECU.

    My ECU has a sticker with these details .... ECU + CAL ASSY 29511270 CIN 070011Y003A -MODEL MD3060 -GOV RPM; 2400 -TYPE; BASIC - PRI MODE 1-6P - SEC MODE; 1-6E TPS; Y - and another sticker with ECU MODULE P?N 29514527 10-11-1993 S?N 2222771 MODEL NO BCU1200.

    Does anyone know if a new ECU is the only cure for this problem and if so where is the best place to get one ? I am in NJ about 30 miles from Johnson and Towers Allison but they don't open until Tuesday. Any Ideas ?

    Fred
     
  2. firepro

    firepro New Member

    Re: Allison 3060 shift pad not lighting or shifting

    Hi Fred, did you ever get this fixed. We have the exact same symptoms. Did you have a wiring diagram?

    Thanks
    Ray
     
  3. Allison Expert

    Allison Expert New Member

    Re: Allison 3060 shift pad not lighting or shifting

    The ECU is the problem. Because it is WTECII it is older and have a tendancy to where out. Go to the allison web site and find the closest dealer and they should be able to get a new ECU and possibly check your old one..
     
  4. C Nash

    C Nash Senior Member

    Re: Allison 3060 shift pad not lighting or shifting

    Hope Fred got his fixed as it was in 2006. :laugh:
     
  5. Allison Expert

    Allison Expert New Member

    Re: Allison 3060 shift pad not lighting or shifting

    Wow, didn't even see that. Thanks :)
     

Share This Page