Atwood Hot Water Heater

Discussion in 'General RVing' started by try2findus, Dec 31, 2008.

  1. try2findus

    try2findus Senior Member

    I have searched back in the forums for info on our Atwood Water Heater. Our 2007 Jayco (bought new in May 08), has suddenly ceased to operate. It will not light although Randy was able to see a small spark yesterday before it got too dark. It is a 6 gallon tank.

    There is water in the unit and we have no idea why it quit working. Another issue which may or may not be related, our cab radio has also quit working. We checked all the fuses and they seem to all be good and for the life of us we cannot figure out why a brand new unit would have electrical problems.

    We have a trip planned for New Year's Day and in prepping the unit we found these new issues. Any suggestions? Thanks in advance!
     
  2. LEN

    LEN Senior Member

    Re: Atwood Hot Water Heater

    Low battery will not allow lighting, so check battery charge. sounds like you have not used RV for a bit so you may have to purge the gas lines. Light the stove top for a few. Then retry hot water and this may take a few times trying. Also check electrical connections to the hot water heater, even though still connected they may not be good.

    LEN
     
  3. try2findus

    try2findus Senior Member

    Re: Atwood Hot Water Heater

    Thank you Len! We will go try that right now. You are correct. Right now our use is limited due to elderly parents so we are not using our unit as much as we would like. We have had low battery issues so that could very well be it. We are just now understanding the battery disconnect switch and will use that from now on when stored. I'll repost shortly.
     
  4. try2findus

    try2findus Senior Member

    Re: Atwood Hot Water Heater

    Well something worked. We had changed the fuse yesterday evening and when we cranked up the unit today to try to charge the battery as Len suggested, the hot water heater did light. So we are not sure if it was the battery or that the unit re-set after changing the fuse. Whatever the case, we now have a functioning hot water heater and are set to head out to Shepard State Park in Mississippi for 3 glorious days!

    Happy New Year to all and thank you again Len! :laugh: :laugh:
     
  5. LEN

    LEN Senior Member

    Re: Atwood Hot Water Heater

    KEWL!!

    Have a good New Year

    LEN
     
  6. Guest

    Guest Guest

    Re: Atwood Hot Water Heater

    ok ,, Len u'r hired ,, report to work on Monday the 5th ;) :approve: :laugh: :laugh: :laugh: :laugh:
     

Share This Page