Electrical Outlets in RV not working

Discussion in 'General RVing' started by Violet22251, Mar 10, 2013.

  1. Violet22251

    Violet22251 Junior Member

    We used our 2012 Winnebago Vista 35F for the first time this weekend. We got all the systems working and we are really happy with it! We have 8 (4 sets of 2) outlets inside that don't work. 2 are on driver's side and 2 are on passenger side - specifically 1 pair in each bathroom, 1 in kitchen, and one in lounge area. At least 1 set of the outdoor sets also don't work - specifically the frontmost storage on passenger side.

    Can anyone give us any ideas of what to do? We want to avoid taking it back to the dealer. We already checked all the circuit breakers in the RV that we could find.

  2. Grandview Trailer Sa

    Grandview Trailer Sa Senior Member

    Sounds like you need to reset the GFI. You will probably find it in the bathroom.
  3. Violet22251

    Violet22251 Junior Member

    Thanks for the quick reply! The owners manual suggested that but none of the outlets have the little GFI buttons on them. Is there someplace we need to look for the GFI?
  4. Grandview Trailer Sa

    Grandview Trailer Sa Senior Member

    Usually the outlet near water has them. You should find them in the Bathroom or in the Kitchen area
  5. Violet22251

    Violet22251 Junior Member

    I know what you mean but they aren't there. Those outlets look just like all the others. No GFI buttons to reset.
  6. C Nash

    C Nash Senior Member

    There has to be a GFI somewhere I would think. Might be outside but never seen one there. Have you tried calling the mfg to ask them?
  7. Violet22251

    Violet22251 Junior Member

    Problem solved. There is a GFCI outlet to your left as you enter the coach. We reset it and all outlets were working again!
  8. H2H1

    H2H1 Senior Member

    great, so glad you found it. I was going to comment as where they was , but I see NASH AND KEN ALREADY MADE THE SUGGESTIONS.

Share This Page