generator problem

Discussion in 'Beginning RVing' started by H2H1, Sep 7, 2010.

  1. H2H1

    H2H1 Senior Member

    OK smart guys hear is a question? A few months while dry camping I ran the MH gas tank down to 1/4 tank and that shut off the genset. I know this iswhat it is suppose to do, but once I filled the gas tank up in the MH the genset will not run any longer than 2 minutes. So does anyone know what I should do to fix this problem? I have changed the fuel filter on it , well the one before the fuel pump anyway. So any ideas as what else I can do before taking it to a shop over 100 miles away. Thanks
     
  2. H2H1

    H2H1 Senior Member

    Re: generator problem

    dang misspell here by hear, sorry, not being smart here
     
  3. Bounder Boy

    Bounder Boy New Member

    Re: generator problem

    Just guessing and asking. Is there maybe some kind of reset you may have to trip? Obviously there is something that trips to shut it off at low fuel level is reached. Just throwing out a thought.
     
  4. Bounder Boy

    Bounder Boy New Member

    Re: generator problem

    Hey, is there a float that would shut off the Gen. at low levels? Maybe that is stuck, or the switch?
    Have you driven the MH around a little after filling it to maybe jar it loose? maybe take a winding road. HA HA see what happens. :question:
     
  5. H2H1

    H2H1 Senior Member

    Re: generator problem

    well John I have driven it about 165 miles and it still does the same thing. I have called every ornan dealer within a 100 miles and they are backed up on repairs on ornan. So I will have to wait till next week and see if I can make a appointment to get someone to look at it. But thanks , good suggestions
     
  6. Guest

    Guest Guest

    Re: generator problem

    Hollis ,, i know u said it runs more ,, the more u start it ,, but one thing ,, is this not under load??? and what does it do if u put a load on it right away after starting it ,, just trying to figure it out ,, and also ,, does it come up to full speed w/o a load on it ,, any stumbling or such ???
     
  7. H2H1

    H2H1 Senior Member

    Re: generator problem

    well Rod , no I have not tried to put a load on it, I guess I should since this question has been asked 2 time already. But once it is running it runs smooth for 2 minutes or so then shuts down. I will go now and start it up and put it under a load and report back.
     
  8. H2H1

    H2H1 Senior Member

    Re: generator problem

    OK I went out side to start the genset, 1st I disconnected from shore power. 2nd I started the genset, started right up, I then turn on one of my air conditioners, genset never hesitated, the ac went back and forth from power to shed, once the compressor kicked is the genset shut down.all this in a matter of 45 seconds, maybe a longer, but not muchmore. I hope this helps out with the problem I am now having.
     
  9. vanole

    vanole Senior Member

    Re: generator problem

    Hollis,

    I know my Onan Quiet Diesel is finnicky when changing fuel filters. Had to make sure I had some fuel in the filter or it would not even run. Another thing have you checked to see if the coolant sensor is firmly connected? Your generator would shut down forthis also but most likely after a couple of minutes.

    Jeff
     
  10. H2H1

    H2H1 Senior Member

    Re: generator problem

    thanks Jeff for that input. Now if I knew where to look for it . I guess I will google it and see if I can find it. Once again thanks for the input.
     
  11. H2H1

    H2H1 Senior Member

    Re: generator problem

    well today I put on all new gas hose, from the tank to the carburetor, still runs 2 minutes. So I guess I will find a shop somewhere that can fix it, just more camping $$$$ going to someone else :(
     
  12. Bounder Boy

    Bounder Boy New Member

    Re: generator problem

    Please report the final outcome, I know a lot of us are interested in learning something new. Good Luck and hopefully it won't be to $$$$$$.
     
  13. H2H1

    H2H1 Senior Member

    Re: generator problem

    OK just for the heck of it, I went and pull off the carburetor off the genset and cleaned it. I put it all back on and started it up. Boy was I surprise it ran until I SHUT IT OFF. I also turned on both air conditioners and it still ran. But I do have to say it not running as smooth as I think it should , so off to the shop anyway on Monday. I will keep U posted as the progress continue :laugh:
     
  14. Guest

    Guest Guest

    Re: generator problem

    good deal hollis ,, u might try some fuel additive before u take it in the big $$$$ at the shop ,, never know ???? ;) :) :)
     
  15. H2H1

    H2H1 Senior Member

    Re: generator problem

    Well this morning I went to see if I did anything wrong on the genset, well found I left a gasket off between the carb and the air breather. well took it back apart out the gasket back on started it back up and now it runs like it suppose to, NOT going to the shop :laugh: Today I also washed the MH from the roof to tires, I swear I think this thing is growing longer and bigger
     
  16. vanole

    vanole Senior Member

    Re: generator problem

    Good job Hollis. Glad to see you discovered the problem and will be able to save a couple of dollars.

    I hate nothing more than washing the motorhome, I too swear they get longer each and everytime.

    Jeff
     
  17. Bounder Boy

    Bounder Boy New Member

    Re: generator problem

    Thanks for the update Hollis, now I know this info will help another save $$ in the future knowing what to look for.
     

Share This Page