Have a slide to my Fifthwheel that won't power in.

Discussion in 'Towables' started by Sunnybrook Fiver owner, Nov 20, 2011.

  1. Sunnybrook Fiver owner

    Sunnybrook Fiver owner Junior Member

    If anyone has any suggestions for me I would appreciate it. I went to leave today and my slide had no power to slide back in. I checked the fuses and they seem to be ok. It had power a couple of days ago as I accidently hit the switch when turning on the outside light. Today there is no sound when I hit the switch. I am leaving for Florida in a week and need to get the slide back in before I leave it here in Michigan. I don't want to leave it out because of the snow. Any help would be appreciated. Sunnybrook Fiver owner
  2. Grandview Trailer Sa

    Grandview Trailer Sa Senior Member

    I got your PM yesterday and forgot about it today, sorry.

    If I have to contact SunnyBrook over this, they will want the last 6 digits of the VIN number. With what you have told me, I would have to think fuse. I know you said you checked them all, but I doubt it. You have not even told me the year of your trailer so I have to do a lot of guessing here. SunnyBrook mounts fuse blocks near the battery. Go to the battery and follow the wires away from it. I think you find several fuses nearby. They are gray rectangular blocks with 2 threaded studs. They have a bi-metal spring in them. I would bet that one has not reset. You would need a test light to check them. You can get replacements at auto parts stores or your local RV dealer. Be sure you match the amp rating.

    If all else fails, you can manually crank it in.

Share This Page