No Spark - Onan 4000 Emerald Spec K

Discussion in 'Talkback' started by jixer, Oct 21, 2013.

  1. jixer

    jixer Junior Member

    I have a spec K Emerald Plus built in March '94: C943138824
    It only has about 530 hours on it which I am told is not really a lot.
    I cleaned out the carb, changed the plugs and filters when I got it and it started and ran like a brand new generator for about 40 hours over a 2 month period. It then started struggling with starting, then would start and run for a few minutes, then die... now it won't run at all. I have determined that it is getting no spark and though I am a mechanic, I don't know much about generators. I have decided that it needs to come out of the RV for testing so I am looking for advice on setting this up and where to start with testing. The manuals I have looked at are far from thorough and message boards are just frustrating. So.... If you were me... where would you begin? I have tools and a good multi-meter, test light etc. as well as big batteries for cranking on the bench etc.
    Thanks in advance.
  2. George-The Old Hippie

    George-The Old Hippie Junior Member

    Check for battery voltage to ign. coil and check the points and cond. if it not elec. ign. system.
    I don't if went to elec. ign. system. Mine still has points and cond.

    I hope this will help you.

  3. C Nash

    C Nash Senior Member

  4. jixer

    jixer Junior Member

    Yes. Checked the oil level, but this brings up a good point. I would like to bypass the oil level sensor to see if its stuck and causing the problem, but I don't know where it is. A good diagram on where the components are located would be most helpful. I am basically trying to do as much trouble shooting as I can before dropping the unit out of the rv which is a major project.
    With only being able to see about 30% of it, it makes it difficult to find the parts and electrical connections.

  5. H2H1

    H2H1 Senior Member

    Nash is right, it has a low oil pressure switch that will keep it from running. DO as he suggest check the oil level before doing all the other things you are talking about
  6. jixer

    jixer Junior Member

    It's not the oil level but it could be the sensor. It would be helpful to have some sort of diagram that tells me where all the components are before I drop it out of the RV. The more I can test before doing that, the better.
  7. jixer

    jixer Junior Member

    Its not the oil level, but it could be the sensor itself. This taps in to one of my essential problems.
    I can easily find all these components, connections, etc. if this thing was sitting on the floor.
    Finding a place to drop the thing out of the rv is a problem for me, so I am trying to do as much diagnosis as I can before having to resort to that. A diagram that locations for components would be helpful, but I cant find that anywhere.

  8. H2H1

    H2H1 Senior Member

    I forgot to add this point, if it is like mine when the gas tank is down to 1/4 tank it will shut down and will not start. In most all motor homes, that is a safety feature to keep you form running out of gas in the MH. I ONLY GUESSING HERE but I am assuming you have one, might be wrong on that , and if so the statement would not be your problem I would think.
  9. LEN

    LEN Senior Member

    Not all that up on gas gens, but here are a couple. Reseat all connections on mother board, check spark without sparkplug, reseat start and shutdown switch connections. And as above gas level which should not be a no spark.
    Here is the Owners manual

    On this model, the oil pressure switch needs to close to ground for the gen to keep running. This is easy, the switch is located next to the oil filter. You will need to remove the cover that is around the oil filter. You will see a wire going to a device that is located right there, it has 1 wire going to it. Remove that wire and jump it to the engine block and start the gen and see what happens. I am still assuming the oil level is good? "Got this from a tip on the net"

  10. Guest

    Guest Guest

    well i can put my 2 cents in for what it is worth ,, since i worked for Cummins and they own the Onan ,, but from what is said ,, sounds like all have mentioned what to look for ,, and thank u all ,,, and i will leave it at that ,, :) :) :p
  11. jixer

    jixer Junior Member

    Not out of gas. It simply isnt getting spark like I explained in the first post.
    That pdf is not the manual for my generator. Thats for a KY. Mine is the more basic Spec K.
    Took the board out and checked all the connections, cleaned all the dust out and replaced it, checked the fuses etc. and all looks good, but still no spark.
    I havent pulled the green cover around the oil filter yet to look for that pressure switch, but that is my next step.
    Thanks for chiming in thus far. I will have more time this weekend to dig in to it.

  12. jixer

    jixer Junior Member

    Sorry it took so long to report back on this. I removed the cover around the oil filter to gain access to the pressure switch, wiggled the connector back and forth a couple times, and she fired right up. I unplugged, tried again, ran a direct ground tried again, and everything operated exactly how you would expect. Buttoned it back up, Runs like a champ, put several hours on it and its all good. So a simple dusty connection on the cheapo spade connector was all it was.
    Thanks for the help guys. Not sure how this would have went without you!

Share This Page