WINNEBAGO TRANSMISSION HELP!!!

Discussion in 'General RVing' started by jamesm, Nov 7, 2009.

  1. jamesm

    jamesm New Member

    Hello, i am not sure where to post this, so sorry if i am in the wrong place... i have a 2003 winnebago journey dl.. the problem i am having is with the WTEC III controller for the allison transmission...the shift pad will not light up at all..i have check the grounds at the controller plug and i do have a constant power on the trans power wire. if i put power to the "sensor power" wire at the plug i get the shift pad to light but not do anything. What should i be looking for...i am totally lost...thanks James
     
  2. dbarton291

    dbarton291 Senior Member

    Re: WINNEBAGO TRANSMISSION HELP!!!

    There is an ignition circuit that is supposed to power the shifter when the key is turned on. I would highly recommend going to www.allisontransmission.com and get one of their WTEC III troubleshooting manuals. There's a publications section of the website from which you can order one. If you're going to do your own troubleshooting, I think you'd really find it to be a big help. It won't have the vehicle wiring in it, but it will at least tell you what all the wires for the Allison are for.
     
  3. dbarton291

    dbarton291 Senior Member

    Re: WINNEBAGO TRANSMISSION HELP!!!

    I forgot to mention one thing. Don't be jumping power to circuits if you don't know what you're doing. Sensor power is normally a five volt output. If you jumped 12 volts input to it, you may damage something.....like your controller.
     
  4. AMSOIL DEALER

    AMSOIL DEALER New Member

    Re: WINNEBAGO TRANSMISSION HELP!!!

    You are correct...

    Allison Needs two signals. One is a direct power wire to battery voltage. The other is a wire off the Ign. side, this is the "wake up" signal to the Allison computer. Should be a fuse for both of these.
     

Share This Page