Allison MD3060 shut down

I had a WTEC II that went to "Do not shift" on the dash when I went to put it in gear. It occurred after driving for about 20 minutes with the air conditioner on, which had a vent that was blowing down on my feet right over the transmission shift ECM unit. I was able to get back home by applying heat to the case (actually heated it with hair dryer periodically). Coming from a background of electronic engineering and repair, I took the cover off the unit, heated it until it worked, and using air guster I started chilling the board in different places until it acted up again, which can be done while powered up. I found a faulty solder joint in the middle of the circuit board just under the main cover. Once it would fail, I would heat the circuit board back up and pin point the cold spray further until I found the specific component/solder joint that had failed. Once the cold hits the bad solder joint, it shuts down. If yours doesn't shut down when chilled, you are probably facing a different issue than I had, but from what I read, this is a very common problem and sounds like a manufacturing problem that affected most of these units.

Some salvage yards want $2000 for these things and no guarantee. If you don't know what you are doing, send it off, but if you have a little spirit and have done this kind of stuff before you will save some money, no re calibration necessary, maybe even continue your trip in a couple of hours. After I had soldered one of these two resistors (see, outlined in red), I could no longer get the cold spray to shut the unit down and it has been working without trouble for almost a year now. I even went out during the dead cold of winter to test it and smiled each time it worked. Don't even have to remove the board from the unit, just take the metal cover off and check it out. If you decide to solder, make sure you have a quality fine point tip gun. You will have to use your fingernail to scrap back some of the rubbery protectant stuff they applied. Also, these are surface mounted resistors and you need a 3rd hand to hold the resistor in place while re-soldering because the other end of the tiny resistor will de-solder as well and it will be a full fledged resistor soldering rodeo.
HELP!! A very old post indeed however, there are those of us that have been searching for a long time. I have a 1997 Fleetwood Discovery Diesel pusher with the MD3060 and the WTEC II shifter. Two years ago after driving about 4 hours I hopped of in a Wally World parking lot for some supplies. When I got back to the RV, cranked right up and had "CatEyes" in the display. Could not do anything. No shifting into drive or reverse. After a few phone calls to Freightliner NDF some looking around for the (which to this day I still haven't found) TCM, I JD to give up for the night due to darkness. By recommendation of Freightliner I hit the disconnects on all power for the night. Woke the next morning and everything was fine. Cranked up and drove the remaining two hours to my camp site but the display digits were flickering and would black out, then come back on. The trip home a weeks later and there were no problems. Left it parked until Fathers Day last year. On the one hour drive to the camp ground for Fathers Day, the display flickered and blacked out a couple of times but I made it ok. Drove it home the following Monday without issues except a bit of flickering. I still haven't found the TCM but I did easily locate the VIM. This is the black box forward of the driver area that contains the 6 relays and two 10 amp fuses. The fuses are good. The relays (according to how I checked them per the YouTube video) are good as well. I decided to go on the hunt again today for the TCM and again, I cannot locate it. Much more reading today and I read that there's a third monster called the "ECU" and this rascal is supposed to be either a part of or on the back of the shifter? My shifter appears to be 2 1/2 inches thick. Before I began looking at the shifter, I cranked up, raised the jacks and leveled. When I did this the display was fine. When I went back outside after more reading, I cranked up and "CatEyes" on the display. I have never seen CatEyes until over an hour into the drive. Anyway, I started in the shifter but had to stop to tend to something else and will either remove it tomorrow or Monday. Anyone know what exactly is going on here other than the "Failure to communicate"? Is my ECU on my WTEC II shifter? Do I need to check the TCM? Where is my TCM? Did I properly check my VIM? Any help would be appreciated as this started in November 2013. Thanks
After 1.5 years of intermittent searching I found the TCM by accident. Standing in front of the RV, directly in front of the driver, open the access door (what you would call the "HOOD" if it were a gasser") and you will see a big black box labeled "Chasis Electrical". Inside this box is where my TCM was. After talking to John at "Transmission Instruments" in Flower Mound Texas and explaining my problems to him, he said that either my TCM, Shifter or wiring was bad but he could rule out two of three possibilities. Per his request I removed the WTEC2 Shifter pad and the WTEC2 TCM (also referred to as an ECU) packaged them securely in a box with bubble wrap and shipped them to him. They contacted me Friday and told me they had received the units. I will update this post when I receive information from John or when and if I have everything back in place and my issue is resolved. I tried to upload photos but the forum tells me "Invalid_attachment_storage", then as I try to post "reply", I get an error message asking me to please upload at least one photo, lol